Travel admin (Rucio workshop)
Writing up some bits on StoRM RSE integration debugging, committing changes to Rucio extended client.
Uploaded 1TB cube to datalake using this extended client w/ 3 month lifetime and then downloaded.
Meetings + bits of career matrix
Mostly debugging
More china src debugging.
Expanded STFC RSE storage and generated 1TB dummy cube + attempted upload but "failed" ~half way through due to requests to storage timing out.
System demo in morning.
Fixed ArgoCD. Intermittent 502s were a LB issue, changing pool algo from round_robin to source_ip fixed it.
Having issues putting files via Davix on CNSRC. Asked Shaoguang for debugging info.
Debugging CNSRC issues.
Preparing for SRC ART systemdemo about hierarchical data storage in Rucio.
Mostly sdcss: Fixed build images, updated README, removed some sensitive token info from repo + added simon and philippa as devs.
Debugging argo in the morning.
Looking through sdcss readme and trying to get images to build (ska_sdc scoring package isn't building).
Meetings incl/ SDCSS handover part 1.
Looking over sdcss.
Meetings.
Getting an ip allowlist for china src.
Looking over sdcss.
Some correspondence with Mihai about davix upload timeout issue
Added JPSRC after (just required a storage server restart).
Added Rook provisioner to new ceph cluster.
Added ability for any user to call update_replica_states in rucio permissions package (required during upload).
Not able to discern much, passed on to JPSRC sysadmins.
Succeeded in doing hierarchical uploads (via machine local to storm storage) and multi-machine downloads (required proxy_buffering to be set to off on the nginx path).
Installed Rucio 1.29.6 as i want to do this before making an image with permission packages included (so I don't have to do it twice). Had some issues with trace server being automatically started in this version (expects config items to exist!).
Installed permission package with any user access to add_replicas function. Sent email to cern dmc support asking about davix client hanging when uploading larger files (as part of sdc3 data upload testing). Tried (and failed) to add jpsrc - some issue with PUTting files that causes a read error (even though file is actually uploaded)
Fixed argocd cronjobs not firing, liaised with coral about spsrc rse expired certs, fixed some reaper issues (lingering x509 user proxy).
Test uploading of SDC3 sample data, some issues with uploading from machine outside storage network (longevity of transaction times out?) but otherwise looks OK.
Fixing gitlab CI for unit tests.
Added unit tests, improved on readme, get some sdc3 test data.